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Overview 
List Templates remain a mystery to most users. In the process of delivering 
our Document Forensics classes, we have found that even among document 
experts familiar with this term, the definitions provided will be as numerous 
as the number of people polled. List Templates are often confused with a 
document template. And, to add to this confusion, the List Template is one of 
the least documented feature of Word! Our focus in writing this article is to 
define the term, eliminate incorrect information and share the functionality 
and use of this very important Word feature. 

Word’s Object Model 
Word manages formatting and layout of a document through the Object 
Model. There, commands that determine how text will appear and behave are 
embedded within the appropriate Word object (in Word, they are said to be 
the object’s properties). There are no “codes” to be revealed, because the 
instructions don’t exist in a sequential order in a particular location on the 
page. Instead, they are embedded within an object. 

The most important object in Word is the document itself—the file 
“container.” This is the level in which a List Template lives. It is embedded 
in the document container. The other levels in the Word object model are the 
Section, Paragraph and Character objects. This concept is key for 
understanding how Word collects formatting information and embeds it 
within the appropriate object. All of these objects work together inside of a 
healthy document. 

List Template, a Definition 
A List Template is a single numbering scheme present in a document. If a 
document contains a bulleted list, a numbered list and an outline numbered 
list, all in use, this would be defined as having three “active” List Templates. 
In addition, other List Templates may be present but not currently in use. A 
List Template contains the “instructions” as to how a particular numbering 
definition (bulleted, single list or outline) will behave and be displayed 
within the document. 

There are several List Template issues which impact Word 97, Word 2000 
and Word 2002 documents: 

First, there is no easy method to determine the number of List Templates 
present in a document. 

Second, once a List Template is part of a document, it cannot easily be 
deleted or removed. 

Third, it is easy to inadvertently add additional, unnecessary list 
templates to your document. 



 

Finally, this build-up of List Templates can negatively impact the overall 
health and stability of your document. 

NOTE: The build up of excess list templates is an issue only in Word 97 and 
Word 2000. Word 2002 manages list templates effectively. 

The List Gallery 
Templates are the base of all Word documents. By default, even in a blank 
document, the template in use is the Normal template. The List Template 
Object, the programmatic term referring to a List Template, is a member of 
the List Template Collection. Each of the seven formats (excluding None) 
found on each of the three tabs in the Bullets and Numbering dialog box 
corresponds to a List Template object. 

One place to keep a List Template object is in a List Gallery object. This is 
viewed when you select Format > Style > (select or create a style name) > 
Modify > Format > Numbering to define or edit a numbering scheme. 
There are three List Gallery objects represented by three tabs within the 
Bullets and Numbering dialog box. The collection of these three List Gallery 
objects, Bulleted, Numbered and Outline Numbered, is the List Gallery 
collection. 

 

This overall 
collection is the 
List Gallery 

Each tab contains 
a List Object 

Each List Object 
displays a 
collection of 7 list 
templates 

This overall collection of 21 list templates is the List Gallery. These 
predefined List Templates can be accessed through the three List Gallery 
Objects (tabs in the Dialog box) held in the List Galleries collection. 
Documents and templates may also contain a collection of list templates. 
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Each List Gallery object contains exactly seven List Template objects, which 
must be of a specific gallery type: bulleted, numbered single-level, or outline 
numbered. Word has not supplied any method for removing a List Template 
object from a List Template collection. If you change the formatting of an 
existing list in a document, and fail to follow Word’s best practices, Word 
will add a new List Template to the document’s List Template collection. 
However, if you delete a numbered style, or simply replace the applied 
numbered style with another style, Word 97 and Word 2000 do not remove 
the List Template object which was created when the numbering was 
originally defined in your document. It remains there, unused. 

As stated above, the build up of excess List Templates is an issue only in 
Word 97 and Word 2000. Word 2002 will recognize if a documents 
collection of List Templates becomes too high and will remove the excess 
List Templates from the document. 

The Template Gallery is Word’s offering to eliminate some of the initial set-
up in using a single-level bulleted list, a single-level numbered list or a multi-
level, outline numbered list. The goal of the List Gallery was to expand the 
range of templates available to Word users, starting in Word 97, and make it 
easier to design new documents without starting from scratch. 

Single and Multi-level Lists 
As stated above, there are three types of lists in Microsoft Word: single-level 
bulleted, single-level numbered and multi-level outline numbered. The term 
outline numbered is a bit misleading, since an outline numbered list can 
include either bullets or numbers on various levels, but it need not include 
any numbers at all. But, since these are Microsoft terms, we will use them in 
this article. 

 Can Be 
Numbered 

Can Be 
Bulleted 

Typical Use 

Single-level 
bulleted 

 X Bulleted list in body of document, and can also 
be located inside a table. 

    
Single-level 
numbered X  Single-level numbered list in body of 

document, and can also be located inside a 
table. A single-level numbered list is often used 
in the following scenarios: 

• In conjunction with a multi-
level outline numbered list to supplement 
available levels. 

• Preceding the start of a multi-
level outline numbered list as in Recitals. 

• Following a multi-level outline 
numbered list as in Schedules. 

• In simple documents not 
requiring a multi-level outline numbered 
scheme. 
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Multi-level 
outline numbered X X Multi-level outline numbered list which is 

typically located in the body of a document, but 
can also be located inside a table. Various 
levels in this type of list can be numbered, 
bulleted, or neither.  

A complex document can contain more than 
one multi-level outline numbered scheme. It is 
common to find one scheme applied in the 
body of the document, with a separate scheme 
applied in the schedules following the main 
body of the document. 

    

How do numbered lists differ from bulleted lists? 

In the case of numbered lists (single and multi-level), there are options to 
either restart the numbering or continue the numbering started in a previous 
list. If there is text between the list you are creating and a previous list, 
Word’s default behavior is to continue the numbering from the previous list. 

For numbered lists, you can customize the numbering by setting the number 
format, the amount of indent, and so on. For multi-level lists, this can be 
done for each level separately, but operating within the scheme. Word does 
not think of lists in the same way as we might. To Word, a document has 
some paragraphs that are formatted with a list format and some paragraphs 
that are not. These paragraphs may or may not be consecutive. 

The Word object model has a List object, which you might think represents a 
straight list. However, according to the Microsoft Word Help documentation, 
a List object represents “a single list format that’s been applied to specified 
paragraphs in a document.” In other words, a List object represents a list 
format. 

The Word object model also has a List Format object, which, according to 
the Microsoft Help documentation, represents “the list formatting attributes 
that can be applied to the paragraphs in a range.” Word considers a single-
bullet list format as a single list object. This is in keeping with the 
information in the Help documentation that says a List object represents a list 
format that has been applied to a document. Translated, this means a single 
list object may contain paragraphs that are not contiguous and can run 
throughout a document. 

Consider now the case of numbered lists. When a numbered list is involved, 
it is the restarting of the numbering that determines a new List object, not a 
change in the list format, as shown in the following graphics: 



 

 

The above example continues the single numbered list and uses one List 
Template. 

 

Numbering 
restarted for List 
Number style 

The number in the above list is restarted following a body text paragraph.  
This adds an additional List Template to the document. 

How many List Templates are too many? 
The goal is to keep the number of List Templates in a document as small as 
possible. They continue to build in a Word 97 or Word 2000 file, until they 
become problematic. Even before the point where you receive warning 
messages regarding the number of List Templates attached to a file, the 
overhead is adding unnecessary complexity to your document. The number 
of List Templates in a document which warrants a warning begins at 1100. 
More than 1100 List Templates in a document will cause a warning to 
display upon opening. An example of such an error message follows: 
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Following the suggested steps in the warning message will not stop the error 
message if List Templates are the cause, as they will travel with the content 
into the new document. 

Determining the Number of List Templates in a Document 
This is probably the largest contributing factor to the confusion surrounding 
List Templates. There is no place within a Word document where you can go 
to determine the number of List Templates present. It is not available through 
a menu option, document properties or Recover Text from Any File. It is 
simply there and monitored only by Word. 

Visual Basic Editor 

Within VBA code, you are able to determine the number of List Templates 
attached to a document. In any file, to programmatically query the number of 
List Templates in a document, complete the following steps: 

1. In your Word document, select Tools > Macro > Visual Basic 
Editor or simply <Alt+F11>. 

2. In the Visual Basic Editor, select your document in the Project 
Window. 

3. Choose View > Immediate Window, or <Ctrl+G>. 

4. In the Immediate Window, type in the following: 

?Activedocument.ListTemplates.Count 
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Project 
Window 
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Immediate 
Window 

1. Press Enter after the line of code and the number of List 
Templates in the document will appear on the line following the 
entered text. 

Using VBA 

To make the task of determining the number of list templates present in a 
given document a little easier, the following VBA code will count the 
number of List Templates in a document. This code can be added as a toolbar 
button for easy access or to run as a macro. 

Sub MyListTemplateCounter() 
 
‘ *************************************************** 
‘ Counts defined List Templates in the active document 
‘ ******************************************************* 
 
    MsgBox “This document has:” & vbCr & _ 
        “     “ & ActiveDocument.ListTemplates.Count & vbCr & _ 
        “defined List Templates.”, vbOKOnly + vbInformation, “List 
Template Counter” 
End Sub 
 

Steps to Add Macro to the Document: 
If you would like to add this code as a stored macro, follow the steps below: 



 

1. Copy the macro text that is listed above. 

1. Go to Tools > Macro > Macros. 

2. Choose which template you would like to store the macro in and 
select it from the Macros in: field. 

3. Type a name for the macro in the Macro name: box. 

 

Name your macro in 
the Macro name: 
box 

Select the template 
to store the macro. 

1. Choose Create. 

2. Paste the copied text from above into the Visual Basic Editor as 
shown below: 
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1. Close the Visual Basic Editor. 

2. Save the template. 

To Add the Macro as a Toolbar Button: 
To add this macro as a toolbar button, complete the following steps: 

1. Navigate to Tools > Customize. 

2. On the Commands tab, in the Categories: field, choose 
Macros. 

3. Drag your List Template macro that is listed in the Commands: 
box onto the toolbar on which you would like to have the button 
available. 

Microsystems – THE document experts 9 List Template 
ListTemplates Why Should I care - 06.12.08 - 6/26/2008 3:34:30 PM 



 

 

Drag the macro 
to the toolbar of 
your choice. 

1. To change the name of the button, with the Customize dialog 
box still open, right-click on the new button as it is displayed on 
the toolbar. 

2. Type in the name of the button in the Name: box as shown 
below: 

 

Rename 
your button. 

Change the 
button image. 
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1. Choose Change Button Image if you would like to add an icon 
to your button. 

 

1. After changing the button name and image, choose Close on the
Customize dialo

 
g box. 

2. Select the button to run the macro. You will receive a message 
similar to this: 

 

DocXtools and Lis

ause any 
build up of List Templates adds to the complexity and overhead of a 

ause errors to be generated until the 

The Document Discovery Report (DocXRx > Document Discovery Report) 
also reports the number of List Templates present in a given document. 

t Template Information 

Am I A Bad Document? 
Am I A Bad Document? will display a notification if there are 500 or more 
List Templates in your document. We provide this information bec

document, even though they do not c
number of List Templates contained in a document reaches 1100. 

Document Discovery Report 

 

List Template 
Count 

How List Templates
There are several ways in which a List Template will be added to a 
document. The table below explains the various ways in which this can 
occur: 

 are Added to a Document 



 

Choosing the wrong 
rabbit hole: 

Editing a numbered style, once you are at the Customize Numbering dialog 
box. If you select a gallery view other than the one that is active, you will 
add an additional List Template to your document. The active List Template 
will be the one in the view that has the border highlighted. In the graphic 
below, this would be the last scheme in the second row: 

 

 

Switching between 
bulleted and 
numbered lists: 

Navigating between bulleted and outline styles can add a List Template. This 
is a documented issue in Word 97, although an error message is never 
displayed. See Microsoft TechNet Article “This Document May Be Corrupt” 
After Switching Between Bullet and Number List Format

Restart a list When a numbered list is involved, it is the restarting of the numbering that 
determines a new List object, not a change in the list format. 

Updating styles: If you update a document with styles, either through the use of Style Gallery 
or the Organizer, don’t count on it updating the List Template you desire. It 
may add one or more List Templates, in addition to any currently in use. 

{ ListNum } field: Inserting a “LISTNUM” field code into a document can be another source. 
This is particularly true when there wasn’t a { ListNum } field or an outline 
list in the document previously. 

Automation: Another source of unwanted List Templates is automation of any type, the 
purpose of which is to introduce List Templates into the document. Since 
they can’t be deleted, the more often the user does this, the more List 
Templates that are likely to be added. 

File > Open a File > Open a WordPerfect 6.x level document into Word. If the original file 
contained automated numbering (Para or Outline), you will have introduced 

The “rabbit hole” is 
surrounded by a 
dark border 
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WordPerfect 
document: 

List Templates. 

What does this mean to your document? 

So, now that you know the technical side of things, you are most likely 
asking yourself, what does this mean to your document? When a scheme is 
edited, Word actually adds another List Template to your document, if you 
fail to faithfully follow Word’s best practices for working with a 
numbered document. When you edit a scheme, you may actually be 
creating a new scheme, not replacing the old scheme. Therefore, when you 
access the Customize Numbering dialog box again, a new List Template 
suddenly appears in the gallery. It looks exactly like the old one. This also 
explains why the rabbit hole moves. The scheme you were editing previously 
is still in your document, but it is no longer the active scheme because you 
have made improper edits to it. Where Word places the ‘new’ active scheme 
is random, to the best of our knowledge. We have never detected a pattern. 

The scenario described above can only occur if you do not follow the correct 
editing rules for outline numbered schemes. If you “dig to China” (Format > 
Style > Modify > Format > Numbering > Customize) and then select the 
correct “rabbit hole” each time you change information in the scheme, a new 
template is not added. Define indents through the paragraph dialog box or 
choose the wrong rabbit hole, and suddenly a new List Template is in the 
document to stay. We have seen Word files with upwards of 2,000 List 
Templates present in a single file. Imagine the stories that document could 
tell! 

This is why it is absolutely crucial that you only choose the highlighted 
rabbit hole. Word is telling you which of the List Templates are active in 
your document. Failure to choose the correct List Template is where the link 
back to the styles is broken. Only the active List Template contains the 
necessary links. 

When a numbered list is involved, it is the restarting of the numbering that 
determines a new List object, not a change in the list format. For more 
information regarding proper numbering practices, refer to The Seven Laws 
of Word’s Outline Numbering. 

Resetting the List Gallery Views 
Have you ever gone into the List Gallery and found that all of the views 
appear the same? How can you get them back to the “original” view where 
you have a choice when you come into this screen? 

The List Gallery object retains the recently used List Templates in the 
Customize Numbering Dialog box, even when they are not present in the 
current document that is open. If you want to clear the seven views and 
default back to the basic Word List Template views, simply select each view 
and then choose the Reset button on the bottom of the Customize Numbering 
Dialog box. 

http://www.microsystems.com/fra_sevenlawsofoutlinenumbering.htm
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By doing this, you are simply resetting the ‘view’. You are not adding List 
Templates to the document. 

 

Steps To Reset a List 
Template: 
1. Select a List Template 
2. Select Reset 

If this is less confusing, especially in a new document, you can do this as a 
standard practice. 

Please note: We do not recommend resetting the List Gallery view when a 
‘rabbit hole’ is already selected. Ensure that the style has not been previously 
setup with outline numbering and the None option is highlighted. 

How to remove List Templates from a Document 

Word 97 and Word 2000 

Previously, the only known way to remove List Templates from a document 
is to bring the document back down to Word 6/95. Word 6/95 does not 
support List Templates. Therefore, when the document is brought back down 
to Word 6/95 the List Templates are removed. 

To save the document down to Word 6/95, simply choose Word 6.0/95 
(*.doc) in the Save as type dropdown box when saving the document. 
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Save as type: 

If you choose this method, however, you must be aware that many features 
commonly used in Word 97 or Word 2000 will not operate properly, if at all, 
in a Word 6/95 document. This would include, but is not limited to, the 
following: 

Table formatting capabilities. 

Graphics 

Picture bullets. 

Numbering 

In addition, you will have to completely renumber your document when you 
open it back in Word 97 or Word 2000. 

Word 2002 

Editing a Word 97 or Word 2000 document in Word 2002 now removes List 
Templates! Excess List Templates which reside in a document can be 
removed by opening and saving the document in Word 2002. Next, bring the 
document back to Word 97 or Word 2000, unburdened of any List Template 
build up. An awareness after doing this task would be resetting the 
compatibility options appropriately back to Word 97 or Word 2000. For 
information regarding sharing documents between versions of Word, read 
Doing the Word 97 and Word 2000 Shuffle and WD2002: A Document 
Forensics Discussion
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Questions and Answers 

Multiple Outline Schemes 

Question 
How many different Outline schemes can you have in a 
document? Will too many lead to corruption? Can you have 
an Outline within an Outline? 
We do not recommend inserting an outline within an outline. We have 
always recommended the use of a List Number style or a List Bullet style if 
you have a special need in one area of a numbered document which cannot 
be handled within a multi-level outline numbered scheme. 

One of the most important things to remember is that a firm document is an 
integral part of a firm’s identity. When anyone outside your firm reviews a 
document, they are also able to judge your understanding of and ability to 
work in Word. When reviewed by a client, they know that a document that is 
not streamlined and created using straight-forward methods will cost more 
because editing time will be lengthened. 

Similarly, a well constructed document conveys a firm’s knowledge and skill 
to the world. This translates to less focus on the document construction and 
more focus on the document content. The end result, which benefits both 
your firm and the client, are reliable documents that are filed on time, 
without issue. 

Another issue to consider is the sheer complexity of the numbering in 
documents where this may be implemented. Word is very unforgiving when 
it comes to best practices in numbering. Failure to follow the rules will result 
in unexpected results. These results could cause numbers to disappear or 
increment outside the expected pattern, collapsing indents, unreliable results 
using restart or continue and failed comparison sessions. 

Another disadvantage comes from the labor involved in maintaining such 
documents. This will impact your internal staff, as well as clients and others 
with whom you may share your documents. It is almost guaranteed that any 
documents which return to your firm will have broken numbering, resulting 
in increased labor costs to repair the damage. Further, your end-users will be 
extremely frustrated. 

Multiple Numbered Lists 

Question: 
How many numbered lists can you have in a document? And 
can the lists fall within the chosen Outline scheme? Will too 
many independently numbered lists lead to corruption? 
Numbered lists are designed to be used alone or in conjunction with outline 
numbered lists. It is acceptable practice to use them in conjunction with 
outline lists to fit special document needs. This can include, but is not limited 
to, areas such as Definitions and Recitals. It is also common to see numbered 
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lists in Schedules where there is a straight-forward, single numbered list in 
place. 

The one caution on too many lists is simply confusion to the users that have 
to edit the document, internally and externally. When numbering is not edited 
using the correct method, it will be much harder to troubleshoot with 
multiple lists. Also, as noted above, the restarting of a numbered list will 
cause an additional List Template to be introduced into your document. 
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